When attempting to configure an external webserver for ColdFusion MX or JRun with the wsconfig utility, if the Java executable used to run wsconfig is version 1.5 or greater then this error will occur.

Trying to force java 1.5 to be compatible with 1.4 getters with the -Djmx.invoke.getters=true switch did not work.

The solution was to use a 1.4.x java executable to run wsconfig.

(click for larger image)

Exception occured trying to get an MBean